summaryrefslogtreecommitdiffstats
path: root/framework/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'framework/CMakeLists.txt')
-rw-r--r--framework/CMakeLists.txt61
1 files changed, 55 insertions, 6 deletions
diff --git a/framework/CMakeLists.txt b/framework/CMakeLists.txt
index ebe308c6..fda9b0a2 100644
--- a/framework/CMakeLists.txt
+++ b/framework/CMakeLists.txt
@@ -22,6 +22,7 @@ find_package(Sink CONFIG REQUIRED)
22find_package(KAsync CONFIG REQUIRED) 22find_package(KAsync CONFIG REQUIRED)
23find_package(QGpgme CONFIG REQUIRED) 23find_package(QGpgme CONFIG REQUIRED)
24find_package(KF5Codecs CONFIG REQUIRED) 24find_package(KF5Codecs CONFIG REQUIRED)
25find_package(KF5Package CONFIG REQUIRED)
25 26
26set(CMAKE_AUTOMOC ON) 27set(CMAKE_AUTOMOC ON)
27add_definitions("-Wall -std=c++0x -g") 28add_definitions("-Wall -std=c++0x -g")
@@ -34,18 +35,66 @@ enable_testing()
34set(SINK_RESOURCE_PLUGINS_PATH ${QT_PLUGIN_INSTALL_DIR}/sink/resources) 35set(SINK_RESOURCE_PLUGINS_PATH ${QT_PLUGIN_INSTALL_DIR}/sink/resources)
35set(FRAMEWORK_INSTALL_DIR ${QML_INSTALL_DIR}/org/kube/framework) 36set(FRAMEWORK_INSTALL_DIR ${QML_INSTALL_DIR}/org/kube/framework)
36 37
37install(DIRECTORY qml DESTINATION ${FRAMEWORK_INSTALL_DIR}) 38install(DIRECTORY qml/ DESTINATION ${FRAMEWORK_INSTALL_DIR})
38install(FILES qmldir DESTINATION ${FRAMEWORK_INSTALL_DIR}) 39install(FILES qmldir DESTINATION ${FRAMEWORK_INSTALL_DIR})
39 40
41set(SRCS
42 frameworkplugin.cpp
43 actions/action.cpp
44 actions/actionhandler.cpp
45 actions/actionbroker.cpp
46 actions/actionresult.cpp
47 actions/context.cpp
48 settings/settings.cpp
49 domain/attachmentmodel.cpp
50 domain/maillistmodel.cpp
51 domain/folderlistmodel.cpp
52 domain/actions/sinkactions.cpp
53 domain/objecttreesource.cpp
54 domain/stringhtmlwriter.cpp
55 domain/composercontroller.cpp
56 domain/messageparser.cpp
57 domain/messageparser_new.cpp
58 domain/messageparser_old.cpp
59 domain/mailtemplates.cpp
60 domain/modeltest.cpp
61 domain/retriever.cpp
62 domain/outboxmodel.cpp
63 domain/identitiesmodel.cpp
64 domain/recepientautocompletionmodel.cpp
65 domain/settings/accountsettings.cpp
66 domain/selector.cpp
67 domain/completer.cpp
68 domain/controller.cpp
69 domain/outboxcontroller.cpp
70 domain/mailcontroller.cpp
71 domain/foldercontroller.cpp
72 domain/mouseproxy.cpp
73 domain/contactcontroller.cpp
74 domain/peoplemodel.cpp
75 accounts/accountfactory.cpp
76 accounts/accountsmodel.cpp
77 notifications/notificationhandler.cpp
78)
79
80add_library(frameworkplugin SHARED ${SRCS})
81
82qt5_use_modules(frameworkplugin Core Quick Qml WebKitWidgets Test)
83target_link_libraries(frameworkplugin sink mimetreeparser KF5::MimeTreeParser KF5::Codecs KF5::Package KAsync)
84
85install(TARGETS frameworkplugin DESTINATION ${FRAMEWORK_INSTALL_DIR})
86
40# The actions framework 87# The actions framework
41add_subdirectory(actions) 88#add_subdirectory(actions)
42# The settings framework 89# The settings framework
43add_subdirectory(settings) 90#add_subdirectory(settings)
44# Domain specific domain logic 91# Domain specific domain logic
45add_subdirectory(domain) 92#add_subdirectory(domain)
46# The accounts framework 93# The accounts framework
47add_subdirectory(accounts) 94#add_subdirectory(accounts)
48# The notifications framework 95# The notifications framework
49add_subdirectory(notifications) 96#add_subdirectory(notifications)
97add_subdirectory(domain/actions/tests)
98add_subdirectory(domain/mimetreeparser)
50 99
51feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES) 100feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)