summaryrefslogtreecommitdiffstats
path: root/accounts/maildir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/maildir/CMakeLists.txt')
-rw-r--r--accounts/maildir/CMakeLists.txt20
1 files changed, 15 insertions, 5 deletions
diff --git a/accounts/maildir/CMakeLists.txt b/accounts/maildir/CMakeLists.txt
index efd0ec6a..b321f0ad 100644
--- a/accounts/maildir/CMakeLists.txt
+++ b/accounts/maildir/CMakeLists.txt
@@ -19,7 +19,7 @@ include(KDEInstallDirs)
19include(KDECMakeSettings) 19include(KDECMakeSettings)
20include(KDECompilerSettings) 20include(KDECompilerSettings)
21 21
22find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui) 22find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Concurrent Quick Test Gui)
23 23
24find_package(Sink CONFIG REQUIRED) 24find_package(Sink CONFIG REQUIRED)
25find_package(KAsync CONFIG REQUIRED) 25find_package(KAsync CONFIG REQUIRED)
@@ -33,12 +33,22 @@ set(SRCS
33) 33)
34 34
35add_library(maildiraccountplugin SHARED ${SRCS}) 35add_library(maildiraccountplugin SHARED ${SRCS})
36qt5_use_modules(maildiraccountplugin Core Quick Qml) 36target_link_libraries(maildiraccountplugin
37target_link_libraries(maildiraccountplugin sink frameworkplugin) 37 sink
38 frameworkplugin
39 Qt5::Core
40 Qt5::Quick
41 Qt5::Qml
42)
38 43
39add_library(maildiraccount_static STATIC ${SRCS}) 44add_library(maildiraccount_static STATIC ${SRCS})
40qt5_use_modules(maildiraccount_static Core Quick Qml) 45target_link_libraries(maildiraccount_static
41target_link_libraries(maildiraccount_static sink frameworkplugin) 46 sink
47 frameworkplugin
48 Qt5::Core
49 Qt5::Quick
50 Qt5::Qml
51)
42add_subdirectory(tests) 52add_subdirectory(tests)
43 53
44kpackage_install_package(package org.kube.accounts.maildir "genericqml") 54kpackage_install_package(package org.kube.accounts.maildir "genericqml")