diff options
Diffstat (limited to 'accounts/maildir/CMakeLists.txt')
-rw-r--r-- | accounts/maildir/CMakeLists.txt | 20 |
1 files changed, 15 insertions, 5 deletions
diff --git a/accounts/maildir/CMakeLists.txt b/accounts/maildir/CMakeLists.txt index efd0ec6a..b321f0ad 100644 --- a/accounts/maildir/CMakeLists.txt +++ b/accounts/maildir/CMakeLists.txt | |||
@@ -19,7 +19,7 @@ include(KDEInstallDirs) | |||
19 | include(KDECMakeSettings) | 19 | include(KDECMakeSettings) |
20 | include(KDECompilerSettings) | 20 | include(KDECompilerSettings) |
21 | 21 | ||
22 | find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui) | 22 | find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Concurrent Quick Test Gui) |
23 | 23 | ||
24 | find_package(Sink CONFIG REQUIRED) | 24 | find_package(Sink CONFIG REQUIRED) |
25 | find_package(KAsync CONFIG REQUIRED) | 25 | find_package(KAsync CONFIG REQUIRED) |
@@ -33,12 +33,22 @@ set(SRCS | |||
33 | ) | 33 | ) |
34 | 34 | ||
35 | add_library(maildiraccountplugin SHARED ${SRCS}) | 35 | add_library(maildiraccountplugin SHARED ${SRCS}) |
36 | qt5_use_modules(maildiraccountplugin Core Quick Qml) | 36 | target_link_libraries(maildiraccountplugin |
37 | target_link_libraries(maildiraccountplugin sink frameworkplugin) | 37 | sink |
38 | frameworkplugin | ||
39 | Qt5::Core | ||
40 | Qt5::Quick | ||
41 | Qt5::Qml | ||
42 | ) | ||
38 | 43 | ||
39 | add_library(maildiraccount_static STATIC ${SRCS}) | 44 | add_library(maildiraccount_static STATIC ${SRCS}) |
40 | qt5_use_modules(maildiraccount_static Core Quick Qml) | 45 | target_link_libraries(maildiraccount_static |
41 | target_link_libraries(maildiraccount_static sink frameworkplugin) | 46 | sink |
47 | frameworkplugin | ||
48 | Qt5::Core | ||
49 | Qt5::Quick | ||
50 | Qt5::Qml | ||
51 | ) | ||
42 | add_subdirectory(tests) | 52 | add_subdirectory(tests) |
43 | 53 | ||
44 | kpackage_install_package(package org.kube.accounts.maildir "genericqml") | 54 | kpackage_install_package(package org.kube.accounts.maildir "genericqml") |