summaryrefslogtreecommitdiffstats
path: root/accounts/maildir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/maildir/CMakeLists.txt')
-rw-r--r--accounts/maildir/CMakeLists.txt18
1 files changed, 0 insertions, 18 deletions
diff --git a/accounts/maildir/CMakeLists.txt b/accounts/maildir/CMakeLists.txt
index 1b017328..dc0f02fe 100644
--- a/accounts/maildir/CMakeLists.txt
+++ b/accounts/maildir/CMakeLists.txt
@@ -1,13 +1,5 @@
1project(kube-accounts-maildir) 1project(kube-accounts-maildir)
2 2
3find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Concurrent Quick Test Gui)
4
5find_package(Sink CONFIG REQUIRED)
6find_package(KAsync CONFIG REQUIRED)
7find_package(KF5 REQUIRED COMPONENTS Package Mime)
8
9include_directories(SYSTEM ${KDE_INSTALL_FULL_INCLUDEDIR}/KF5/)
10
11set(SRCS 3set(SRCS
12 maildirsettings.cpp 4 maildirsettings.cpp
13 maildiraccountplugin.cpp 5 maildiraccountplugin.cpp
@@ -22,16 +14,6 @@ target_link_libraries(maildiraccountplugin
22 Qt5::Qml 14 Qt5::Qml
23) 15)
24 16
25add_library(maildiraccount_static STATIC ${SRCS})
26target_link_libraries(maildiraccount_static
27 sink
28 frameworkplugin
29 Qt5::Core
30 Qt5::Quick
31 Qt5::Qml
32)
33add_subdirectory(tests)
34
35kpackage_install_package(package org.kube.accounts.maildir "genericqml") 17kpackage_install_package(package org.kube.accounts.maildir "genericqml")
36 18
37install(TARGETS maildiraccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/maildir) 19install(TARGETS maildiraccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/maildir)