diff options
Diffstat (limited to 'accounts/maildir/CMakeLists.txt')
-rw-r--r-- | accounts/maildir/CMakeLists.txt | 18 |
1 files changed, 0 insertions, 18 deletions
diff --git a/accounts/maildir/CMakeLists.txt b/accounts/maildir/CMakeLists.txt index 1b017328..dc0f02fe 100644 --- a/accounts/maildir/CMakeLists.txt +++ b/accounts/maildir/CMakeLists.txt | |||
@@ -1,13 +1,5 @@ | |||
1 | project(kube-accounts-maildir) | 1 | project(kube-accounts-maildir) |
2 | 2 | ||
3 | find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Concurrent Quick Test Gui) | ||
4 | |||
5 | find_package(Sink CONFIG REQUIRED) | ||
6 | find_package(KAsync CONFIG REQUIRED) | ||
7 | find_package(KF5 REQUIRED COMPONENTS Package Mime) | ||
8 | |||
9 | include_directories(SYSTEM ${KDE_INSTALL_FULL_INCLUDEDIR}/KF5/) | ||
10 | |||
11 | set(SRCS | 3 | set(SRCS |
12 | maildirsettings.cpp | 4 | maildirsettings.cpp |
13 | maildiraccountplugin.cpp | 5 | maildiraccountplugin.cpp |
@@ -22,16 +14,6 @@ target_link_libraries(maildiraccountplugin | |||
22 | Qt5::Qml | 14 | Qt5::Qml |
23 | ) | 15 | ) |
24 | 16 | ||
25 | add_library(maildiraccount_static STATIC ${SRCS}) | ||
26 | target_link_libraries(maildiraccount_static | ||
27 | sink | ||
28 | frameworkplugin | ||
29 | Qt5::Core | ||
30 | Qt5::Quick | ||
31 | Qt5::Qml | ||
32 | ) | ||
33 | add_subdirectory(tests) | ||
34 | |||
35 | kpackage_install_package(package org.kube.accounts.maildir "genericqml") | 17 | kpackage_install_package(package org.kube.accounts.maildir "genericqml") |
36 | 18 | ||
37 | install(TARGETS maildiraccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/maildir) | 19 | install(TARGETS maildiraccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/maildir) |