summaryrefslogtreecommitdiffstats
path: root/accounts/maildir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/maildir/CMakeLists.txt')
-rw-r--r--accounts/maildir/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/accounts/maildir/CMakeLists.txt b/accounts/maildir/CMakeLists.txt
index 7e9894b1..d83ae0be 100644
--- a/accounts/maildir/CMakeLists.txt
+++ b/accounts/maildir/CMakeLists.txt
@@ -20,8 +20,21 @@ include(KDECompilerSettings)
20find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui) 20find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui)
21 21
22set (QT_MIN_VERSION "5.4.0") 22set (QT_MIN_VERSION "5.4.0")
23find_package(KF5 REQUIRED COMPONENTS Package) 23find_package(Sink CONFIG REQUIRED)
24find_package(KF5Async CONFIG REQUIRED)
24 25
26include_directories(SYSTEM ${KDE_INSTALL_FULL_INCLUDEDIR}/KF5/)
27
28set(SRCS
29 maildirsettings.cpp
30 maildiraccountplugin.cpp
31)
32
33add_library(maildiraccountplugin SHARED ${SRCS})
34qt5_use_modules(maildiraccountplugin Core Quick Qml)
35target_link_libraries(maildiraccountplugin sink)
36
37install(TARGETS maildiraccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir)
25install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir) 38install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir)
26install(FILES package/contents/ui/MaildirAccountSettings.qml DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir) 39install(FILES package/contents/ui/MaildirAccountSettings.qml DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir)
27 40