summaryrefslogtreecommitdiffstats
path: root/accounts/maildir/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/maildir/CMakeLists.txt')
-rw-r--r--accounts/maildir/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/accounts/maildir/CMakeLists.txt b/accounts/maildir/CMakeLists.txt
new file mode 100644
index 00000000..7e9894b1
--- /dev/null
+++ b/accounts/maildir/CMakeLists.txt
@@ -0,0 +1,27 @@
1project(kube-accounts-maildir)
2
3cmake_minimum_required(VERSION 2.8.10.1)
4
5include(CPack)
6include(FeatureSummary)
7find_package(PkgConfig)
8
9################# set KDE specific information #################
10
11find_package(ECM 0.0.8 REQUIRED NO_MODULE)
12
13# where to look first for cmake modules, before ${CMAKE_ROOT}/Modules/ is checked
14set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
15
16include(KDEInstallDirs)
17include(KDECMakeSettings)
18include(KDECompilerSettings)
19
20find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui)
21
22set (QT_MIN_VERSION "5.4.0")
23find_package(KF5 REQUIRED COMPONENTS Package)
24
25install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir)
26install(FILES package/contents/ui/MaildirAccountSettings.qml DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir)
27