summaryrefslogtreecommitdiffstats
path: root/accounts/imap/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/imap/CMakeLists.txt')
-rw-r--r--accounts/imap/CMakeLists.txt20
1 files changed, 15 insertions, 5 deletions
diff --git a/accounts/imap/CMakeLists.txt b/accounts/imap/CMakeLists.txt
index 13e6e2ec..259c8e69 100644
--- a/accounts/imap/CMakeLists.txt
+++ b/accounts/imap/CMakeLists.txt
@@ -19,7 +19,7 @@ include(KDEInstallDirs)
19include(KDECMakeSettings) 19include(KDECMakeSettings)
20include(KDECompilerSettings) 20include(KDECompilerSettings)
21 21
22find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui) 22find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Concurrent Quick Test Gui)
23 23
24find_package(Sink CONFIG REQUIRED) 24find_package(Sink CONFIG REQUIRED)
25find_package(KAsync CONFIG REQUIRED) 25find_package(KAsync CONFIG REQUIRED)
@@ -33,12 +33,22 @@ set(SRCS
33) 33)
34 34
35add_library(imapaccountplugin SHARED ${SRCS}) 35add_library(imapaccountplugin SHARED ${SRCS})
36qt5_use_modules(imapaccountplugin Core Quick Qml) 36target_link_libraries(imapaccountplugin
37target_link_libraries(imapaccountplugin sink frameworkplugin) 37 sink
38 frameworkplugin
39 Qt5::Core
40 Qt5::Quick
41 Qt5::Qml
42)
38 43
39add_library(imapaccount_static STATIC ${SRCS}) 44add_library(imapaccount_static STATIC ${SRCS})
40qt5_use_modules(imapaccount_static Core Quick Qml) 45target_link_libraries(imapaccount_static
41target_link_libraries(imapaccount_static sink frameworkplugin) 46 sink
47 frameworkplugin
48 Qt5::Core
49 Qt5::Quick
50 Qt5::Qml
51)
42add_subdirectory(tests) 52add_subdirectory(tests)
43 53
44kpackage_install_package(package org.kube.accounts.imap "genericqml") 54kpackage_install_package(package org.kube.accounts.imap "genericqml")