summaryrefslogtreecommitdiffstats
path: root/accounts/imap/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/imap/CMakeLists.txt')
-rw-r--r--accounts/imap/CMakeLists.txt48
1 files changed, 48 insertions, 0 deletions
diff --git a/accounts/imap/CMakeLists.txt b/accounts/imap/CMakeLists.txt
new file mode 100644
index 00000000..afff7102
--- /dev/null
+++ b/accounts/imap/CMakeLists.txt
@@ -0,0 +1,48 @@
1project(kube-accounts-imap)
2
3cmake_minimum_required(VERSION 2.8.12)
4
5include(CPack)
6include(FeatureSummary)
7find_package(PkgConfig)
8
9################# set KDE specific information #################
10
11find_package(ECM 0.0.8 REQUIRED NO_MODULE)
12
13# where to look first for cmake modules, before ${CMAKE_ROOT}/Modules/ is checked
14set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
15
16include(KDEInstallDirs)
17include(KDECMakeSettings)
18include(KDECompilerSettings)
19
20find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui)
21
22set (QT_MIN_VERSION "5.4.0")
23find_package(Sink CONFIG REQUIRED)
24find_package(KF5Async CONFIG REQUIRED)
25find_package(KF5 REQUIRED COMPONENTS Package)
26
27include_directories(SYSTEM ${KDE_INSTALL_FULL_INCLUDEDIR}/KF5/)
28#FIXME
29include_directories(../../framework/)
30
31set(SRCS
32 imapsettings.cpp
33 imapaccountplugin.cpp
34)
35
36add_library(imapaccountplugin SHARED ${SRCS})
37qt5_use_modules(imapaccountplugin Core Quick Qml)
38target_link_libraries(imapaccountplugin sink settingsplugin)
39
40add_library(imapaccount_static STATIC ${SRCS})
41qt5_use_modules(imapaccount_static Core Quick Qml)
42target_link_libraries(imapaccount_static sink settingsplugin)
43add_subdirectory(tests)
44
45kpackage_install_package(package org.kube.accounts.imap "genericqml")
46
47install(TARGETS imapaccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/imap)
48install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/imap)