diff options
Diffstat (limited to 'accounts/imap/CMakeLists.txt')
-rw-r--r-- | accounts/imap/CMakeLists.txt | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/accounts/imap/CMakeLists.txt b/accounts/imap/CMakeLists.txt new file mode 100644 index 00000000..afff7102 --- /dev/null +++ b/accounts/imap/CMakeLists.txt | |||
@@ -0,0 +1,48 @@ | |||
1 | project(kube-accounts-imap) | ||
2 | |||
3 | cmake_minimum_required(VERSION 2.8.12) | ||
4 | |||
5 | include(CPack) | ||
6 | include(FeatureSummary) | ||
7 | find_package(PkgConfig) | ||
8 | |||
9 | ################# set KDE specific information ################# | ||
10 | |||
11 | find_package(ECM 0.0.8 REQUIRED NO_MODULE) | ||
12 | |||
13 | # where to look first for cmake modules, before ${CMAKE_ROOT}/Modules/ is checked | ||
14 | set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR}) | ||
15 | |||
16 | include(KDEInstallDirs) | ||
17 | include(KDECMakeSettings) | ||
18 | include(KDECompilerSettings) | ||
19 | |||
20 | find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui) | ||
21 | |||
22 | set (QT_MIN_VERSION "5.4.0") | ||
23 | find_package(Sink CONFIG REQUIRED) | ||
24 | find_package(KF5Async CONFIG REQUIRED) | ||
25 | find_package(KF5 REQUIRED COMPONENTS Package) | ||
26 | |||
27 | include_directories(SYSTEM ${KDE_INSTALL_FULL_INCLUDEDIR}/KF5/) | ||
28 | #FIXME | ||
29 | include_directories(../../framework/) | ||
30 | |||
31 | set(SRCS | ||
32 | imapsettings.cpp | ||
33 | imapaccountplugin.cpp | ||
34 | ) | ||
35 | |||
36 | add_library(imapaccountplugin SHARED ${SRCS}) | ||
37 | qt5_use_modules(imapaccountplugin Core Quick Qml) | ||
38 | target_link_libraries(imapaccountplugin sink settingsplugin) | ||
39 | |||
40 | add_library(imapaccount_static STATIC ${SRCS}) | ||
41 | qt5_use_modules(imapaccount_static Core Quick Qml) | ||
42 | target_link_libraries(imapaccount_static sink settingsplugin) | ||
43 | add_subdirectory(tests) | ||
44 | |||
45 | kpackage_install_package(package org.kube.accounts.imap "genericqml") | ||
46 | |||
47 | install(TARGETS imapaccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/imap) | ||
48 | install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/imap) | ||