summaryrefslogtreecommitdiffstats
path: root/accounts/google/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/google/CMakeLists.txt')
-rw-r--r--accounts/google/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/accounts/google/CMakeLists.txt b/accounts/google/CMakeLists.txt
new file mode 100644
index 00000000..3732190d
--- /dev/null
+++ b/accounts/google/CMakeLists.txt
@@ -0,0 +1,19 @@
1project(kube-accounts-google)
2
3set(SRCS
4 googlesettings.cpp
5 googleaccountplugin.cpp
6)
7
8add_library(googleaccountplugin SHARED ${SRCS})
9target_link_libraries(googleaccountplugin
10 sink
11 frameworkplugin
12 Qt5::Core
13 Qt5::Quick
14 Qt5::Qml
15)
16
17install(TARGETS googleaccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/google)
18install(FILES metadata.json DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/google)
19install_qml_account(google)