diff options
Diffstat (limited to 'accounts/gmail/CMakeLists.txt')
-rw-r--r-- | accounts/gmail/CMakeLists.txt | 19 |
1 files changed, 19 insertions, 0 deletions
diff --git a/accounts/gmail/CMakeLists.txt b/accounts/gmail/CMakeLists.txt new file mode 100644 index 00000000..f8baee04 --- /dev/null +++ b/accounts/gmail/CMakeLists.txt | |||
@@ -0,0 +1,19 @@ | |||
1 | project(kube-accounts-gmail) | ||
2 | |||
3 | set(SRCS | ||
4 | gmailsettings.cpp | ||
5 | gmailaccountplugin.cpp | ||
6 | ) | ||
7 | |||
8 | add_library(gmailaccountplugin SHARED ${SRCS}) | ||
9 | target_link_libraries(gmailaccountplugin | ||
10 | sink | ||
11 | frameworkplugin | ||
12 | Qt5::Core | ||
13 | Qt5::Quick | ||
14 | Qt5::Qml | ||
15 | ) | ||
16 | |||
17 | install(TARGETS gmailaccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/gmail) | ||
18 | install(FILES metadata.json DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/gmail) | ||
19 | install_qml_account(gmail) | ||