diff options
Diffstat (limited to 'accounts/generic/CMakeLists.txt')
-rw-r--r-- | accounts/generic/CMakeLists.txt | 23 |
1 files changed, 23 insertions, 0 deletions
diff --git a/accounts/generic/CMakeLists.txt b/accounts/generic/CMakeLists.txt new file mode 100644 index 00000000..f609c2e1 --- /dev/null +++ b/accounts/generic/CMakeLists.txt | |||
@@ -0,0 +1,23 @@ | |||
1 | project(kube-accounts-generic) | ||
2 | |||
3 | find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Qml) | ||
4 | |||
5 | find_package(Sink CONFIG REQUIRED) | ||
6 | find_package(KAsync CONFIG REQUIRED) | ||
7 | |||
8 | set(SRCS | ||
9 | settings.cpp | ||
10 | accountplugin.cpp | ||
11 | ) | ||
12 | |||
13 | add_library(genericaccountplugin SHARED ${SRCS}) | ||
14 | target_link_libraries(genericaccountplugin | ||
15 | sink | ||
16 | frameworkplugin | ||
17 | Qt5::Core | ||
18 | Qt5::Quick | ||
19 | Qt5::Qml | ||
20 | ) | ||
21 | |||
22 | install(TARGETS genericaccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/accounts/generic) | ||
23 | install_qml_account(generic) | ||