diff options
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 5 |
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 350dfea2..321cacf7 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -11,6 +11,8 @@ cmake_policy(SET CMP0053 NEW) | |||
11 | cmake_policy(SET CMP0063 NEW) | 11 | cmake_policy(SET CMP0063 NEW) |
12 | 12 | ||
13 | option(EXPERIMENTAL_VIEWS "Install experimental views" OFF) | 13 | option(EXPERIMENTAL_VIEWS "Install experimental views" OFF) |
14 | #Do not enable this unless you actually distribute a custom extension. | ||
15 | option(ENABLE_EXTENSION "Enable custom kube extensions" OFF) | ||
14 | 16 | ||
15 | include(CPack) | 17 | include(CPack) |
16 | include(FeatureSummary) | 18 | include(FeatureSummary) |
@@ -41,3 +43,6 @@ add_subdirectory(applications) | |||
41 | add_subdirectory(views) | 43 | add_subdirectory(views) |
42 | add_subdirectory(accounts) | 44 | add_subdirectory(accounts) |
43 | add_subdirectory(tests) | 45 | add_subdirectory(tests) |
46 | if (${ENABLE_EXTENSION}) | ||
47 | add_subdirectory(extensions) | ||
48 | endif() | ||