summaryrefslogtreecommitdiffstats
path: root/framework/theme/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2016-03-10 14:45:42 +0100
committerChristian Mollekopf <chrigi_1@fastmail.fm>2016-03-10 14:45:42 +0100
commitced0c73f7e5b8da83a0b5f51bf6220fb04c33cbf (patch)
tree748aca3ddd0b2170427d4f5a47c65090bd193aaf /framework/theme/CMakeLists.txt
parentd8e13159711576394099f8954368aeb9da7fa87a (diff)
parent1f1dbdf5af1af9a83d74113bbdf4132271d6ca51 (diff)
downloadkube-ced0c73f7e5b8da83a0b5f51bf6220fb04c33cbf.tar.gz
kube-ced0c73f7e5b8da83a0b5f51bf6220fb04c33cbf.zip
Merge branch 'develop' of git://anongit.kde.org/kube into develop
Diffstat (limited to 'framework/theme/CMakeLists.txt')
-rw-r--r--framework/theme/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/framework/theme/CMakeLists.txt b/framework/theme/CMakeLists.txt
new file mode 100644
index 00000000..319e3d39
--- /dev/null
+++ b/framework/theme/CMakeLists.txt
@@ -0,0 +1,14 @@
1set(themeplugin_SRCS
2 themeplugin.cpp
3 colorpalette.cpp
4 unit.cpp
5)
6
7add_library(themeplugin SHARED ${themeplugin_SRCS})
8
9qt5_use_modules(themeplugin Core Quick Qml)
10
11target_link_libraries(themeplugin)
12
13install(TARGETS themeplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/theme)
14install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/theme)