summaryrefslogtreecommitdiffstats
path: root/framework/theme/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Bohlender <michael.bohlender@kdemail.net>2016-03-10 12:12:31 +0100
committerMichael Bohlender <michael.bohlender@kdemail.net>2016-03-10 12:13:04 +0100
commit7c7a755f2d87d672ee8afc7d5656971297539fe3 (patch)
treeb9fcaa50ff193024d2a0717d088baae153b0cbfd /framework/theme/CMakeLists.txt
parent8be073696c75fa5bdea4b61c50e0137531f99c3f (diff)
downloadkube-7c7a755f2d87d672ee8afc7d5656971297539fe3.tar.gz
kube-7c7a755f2d87d672ee8afc7d5656971297539fe3.zip
Theme plugin with colorpalette
Diffstat (limited to 'framework/theme/CMakeLists.txt')
-rw-r--r--framework/theme/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/framework/theme/CMakeLists.txt b/framework/theme/CMakeLists.txt
new file mode 100644
index 00000000..4314f662
--- /dev/null
+++ b/framework/theme/CMakeLists.txt
@@ -0,0 +1,13 @@
1set(themeplugin_SRCS
2 themeplugin.cpp
3 colorpalette.cpp
4)
5
6add_library(themeplugin SHARED ${themeplugin_SRCS})
7
8qt5_use_modules(themeplugin Core Quick Qml)
9
10target_link_libraries(themeplugin)
11
12install(TARGETS themeplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/theme)
13install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/theme)