summaryrefslogtreecommitdiffstats
path: root/framework/src/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2017-05-29 16:17:04 +0200
committerChristian Mollekopf <chrigi_1@fastmail.fm>2017-06-04 12:57:04 +0200
commite452707fdfbd61be1e5633b516b653b7337e7865 (patch)
tree1e1d4b48ebf8d381f292436f2ba04b8763edc5de /framework/src/CMakeLists.txt
parent5a1033bdace740799a6e03389bee30e5a4de5d44 (diff)
downloadkube-e452707fdfbd61be1e5633b516b653b7337e7865.tar.gz
kube-e452707fdfbd61be1e5633b516b653b7337e7865.zip
Reduced the messagetreeparser to aproximately what we actually require
While in a much more managable state it's still not pretty. However, further refactoring can now gradually happen as we need to do further work on it. Things that should happen eventually: * Simplify the logic that creates the messageparts (we don't need the whole formatter plugin complexity) * Get rid of the nodehelper (let the parts hold the necessary data) * Get rid of partmetadata (let the part handleit)
Diffstat (limited to 'framework/src/CMakeLists.txt')
-rw-r--r--framework/src/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/framework/src/CMakeLists.txt b/framework/src/CMakeLists.txt
index 64cec905..0e6af2ce 100644
--- a/framework/src/CMakeLists.txt
+++ b/framework/src/CMakeLists.txt
@@ -31,11 +31,9 @@ set(SRCS
31 domain/peoplemodel.cpp 31 domain/peoplemodel.cpp
32 domain/mime/htmlutils.cpp 32 domain/mime/htmlutils.cpp
33 domain/mime/messageparser.cpp 33 domain/mime/messageparser.cpp
34 domain/mime/messageparser_new.cpp
35 domain/mime/mailtemplates.cpp
36 domain/mime/attachmentmodel.cpp 34 domain/mime/attachmentmodel.cpp
37 domain/mime/objecttreesource.cpp 35 domain/mime/partmodel.cpp
38 domain/mime/stringhtmlwriter.cpp 36 domain/mime/mailtemplates.cpp
39 accounts/accountfactory.cpp 37 accounts/accountfactory.cpp
40 accounts/accountsmodel.cpp 38 accounts/accountsmodel.cpp
41 fabric.cpp 39 fabric.cpp
@@ -44,7 +42,7 @@ set(SRCS
44 42
45add_library(frameworkplugin SHARED ${SRCS}) 43add_library(frameworkplugin SHARED ${SRCS})
46qt5_use_modules(frameworkplugin Core Quick Qml WebEngineWidgets Test) 44qt5_use_modules(frameworkplugin Core Quick Qml WebEngineWidgets Test)
47target_link_libraries(frameworkplugin sink mimetreeparser KF5::Codecs KF5::Package KAsync) 45target_link_libraries(frameworkplugin sink kube_otp KF5::Codecs KF5::Package KAsync)
48install(TARGETS frameworkplugin DESTINATION ${FRAMEWORK_INSTALL_DIR}) 46install(TARGETS frameworkplugin DESTINATION ${FRAMEWORK_INSTALL_DIR})
49 47
50add_subdirectory(domain/mime/mimetreeparser) 48add_subdirectory(domain/mime/mimetreeparser)