diff options
author | Michael Bohlender <michael.bohlender@kdemail.net> | 2015-12-20 00:55:34 +0100 |
---|---|---|
committer | Michael Bohlender <michael.bohlender@kdemail.net> | 2015-12-20 00:55:34 +0100 |
commit | 57291511fec8d476f3f7290891bbd2a595f07f43 (patch) | |
tree | 41876c29de2bb73500ac4dbb0429631224444ba1 /framework/settings/CMakeLists.txt | |
parent | 3af80d6bce96009a66cebb0650f1f20cf4ef1be7 (diff) | |
download | kube-57291511fec8d476f3f7290891bbd2a595f07f43.tar.gz kube-57291511fec8d476f3f7290891bbd2a595f07f43.zip |
create initial settings plugin
Diffstat (limited to 'framework/settings/CMakeLists.txt')
-rw-r--r-- | framework/settings/CMakeLists.txt | 14 |
1 files changed, 14 insertions, 0 deletions
diff --git a/framework/settings/CMakeLists.txt b/framework/settings/CMakeLists.txt new file mode 100644 index 00000000..3aca76dd --- /dev/null +++ b/framework/settings/CMakeLists.txt | |||
@@ -0,0 +1,14 @@ | |||
1 | set(settingsplugin_SRCS | ||
2 | settingsplugin.cpp | ||
3 | maildir_resource.cpp | ||
4 | ) | ||
5 | |||
6 | add_library(settingsplugin SHARED ${settingsplugin_SRCS}) | ||
7 | |||
8 | qt5_use_modules(settingsplugin Core Quick Qml) | ||
9 | |||
10 | target_link_libraries(settingsplugin /work/install/lib64/libakonadi2common.so) | ||
11 | #target_link_libraries(settingsplugin /home/mike/projects/_install/lib/x86_64-linux-gnu/libakonadi2common.so) | ||
12 | |||
13 | install(TARGETS settingsplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/akonadi2/settings) | ||
14 | install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/akonadi2/settings) \ No newline at end of file | ||