summaryrefslogtreecommitdiffstats
path: root/framework/mail/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2016-01-21 11:36:43 +0100
committerChristian Mollekopf <chrigi_1@fastmail.fm>2016-01-21 11:36:43 +0100
commitbf96cfa0d75d256e036c76ec64f0f456014f2739 (patch)
tree3ab0ff603dfccb9f28040af3a1559b01af09aa3f /framework/mail/CMakeLists.txt
parente4e11ba46f4ccce5f9ca63ab758a132d945061e8 (diff)
parent9a3059769a0bf9dbf81e523c9245d2aa98420bb5 (diff)
downloadkube-bf96cfa0d75d256e036c76ec64f0f456014f2739.tar.gz
kube-bf96cfa0d75d256e036c76ec64f0f456014f2739.zip
Merge remote-tracking branch 'origin/dev/libotp' into develop
Conflicts: framework/mail/CMakeLists.txt
Diffstat (limited to 'framework/mail/CMakeLists.txt')
-rw-r--r--framework/mail/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/framework/mail/CMakeLists.txt b/framework/mail/CMakeLists.txt
index 6188c93c..9a32cc83 100644
--- a/framework/mail/CMakeLists.txt
+++ b/framework/mail/CMakeLists.txt
@@ -6,14 +6,15 @@ set(mailplugin_SRCS
6 folderlistmodel.cpp 6 folderlistmodel.cpp
7 folderlistcontroller.cpp 7 folderlistcontroller.cpp
8 actions/akonadiactions.cpp 8 actions/akonadiactions.cpp
9 objecttreesource.cpp
10 stringhtmlwriter.cpp
9) 11)
10 12
11add_library(mailplugin SHARED ${mailplugin_SRCS}) 13add_library(mailplugin SHARED ${mailplugin_SRCS})
12 14
13qt5_use_modules(mailplugin Core Quick Qml) 15qt5_use_modules(mailplugin Core Quick Qml)
14 16
15target_link_libraries(mailplugin /work/install/lib64/libakonadi2common.so actionplugin) 17target_link_libraries(mailplugin actionplugin KF5::akonadi2common KF5::Otp actionplugin)
16#target_link_libraries(mailplugin /home/mike/projects/_install/lib/x86_64-linux-gnu/libakonadi2common.so)
17 18
18install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/mail) 19install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/mail)
19install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/mail) 20install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/mail)