summaryrefslogtreecommitdiffstats
path: root/framework/mail/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Bohlender <michael.bohlender@kdemail.net>2015-10-16 17:11:22 +0200
committerMichael Bohlender <michael.bohlender@kdemail.net>2015-10-16 17:12:02 +0200
commit3b455f3b2e557fa4f1ca69c042309612acf7fe59 (patch)
tree71fefae0257e8f706ec5b1b81d429d98697cfa2a /framework/mail/CMakeLists.txt
parentac6cbedf135a3b31596af83bf75843f1fabdf1fb (diff)
downloadkube-3b455f3b2e557fa4f1ca69c042309612acf7fe59.tar.gz
kube-3b455f3b2e557fa4f1ca69c042309612acf7fe59.zip
initial mailplugin with maillistcontroller, model and view
Diffstat (limited to 'framework/mail/CMakeLists.txt')
-rw-r--r--framework/mail/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/framework/mail/CMakeLists.txt b/framework/mail/CMakeLists.txt
new file mode 100644
index 00000000..100b9d9e
--- /dev/null
+++ b/framework/mail/CMakeLists.txt
@@ -0,0 +1,12 @@
1set(mailplugin_SRCS
2 mailplugin.cpp
3 maillistcontroller.cpp
4 maillistmodel.cpp
5)
6
7add_library(mailplugin SHARED ${mailplugin_SRCS})
8
9qt5_use_modules(mailplugin Core Quick Qml)
10
11install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/akonadi2/mail)
12install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/akonadi2/mail) \ No newline at end of file