diff options
author | Christian Mollekopf <chrigi_1@fastmail.fm> | 2016-07-01 09:56:27 +0200 |
---|---|---|
committer | Christian Mollekopf <chrigi_1@fastmail.fm> | 2016-07-01 09:56:27 +0200 |
commit | e5dfbf1d8121a5b50ffd13b8c2f8d8ad7e3cf270 (patch) | |
tree | d23e9a75e179ff105f8962af8709a922dc742499 /framework/domain/CMakeLists.txt | |
parent | 2427b9a3fe02724071800092046ce4f33610d169 (diff) | |
download | kube-e5dfbf1d8121a5b50ffd13b8c2f8d8ad7e3cf270.tar.gz kube-e5dfbf1d8121a5b50ffd13b8c2f8d8ad7e3cf270.zip |
Removed mailtransport that lives in Sink now.
Diffstat (limited to 'framework/domain/CMakeLists.txt')
-rw-r--r-- | framework/domain/CMakeLists.txt | 7 |
1 files changed, 1 insertions, 6 deletions
diff --git a/framework/domain/CMakeLists.txt b/framework/domain/CMakeLists.txt index 8b58296d..114b054d 100644 --- a/framework/domain/CMakeLists.txt +++ b/framework/domain/CMakeLists.txt | |||
@@ -3,13 +3,11 @@ set(mailplugin_SRCS | |||
3 | maillistmodel.cpp | 3 | maillistmodel.cpp |
4 | folderlistmodel.cpp | 4 | folderlistmodel.cpp |
5 | actions/sinkactions.cpp | 5 | actions/sinkactions.cpp |
6 | actions/mailactions.cpp | ||
7 | objecttreesource.cpp | 6 | objecttreesource.cpp |
8 | stringhtmlwriter.cpp | 7 | stringhtmlwriter.cpp |
9 | csshelper.cpp | 8 | csshelper.cpp |
10 | composercontroller.cpp | 9 | composercontroller.cpp |
11 | messageparser.cpp | 10 | messageparser.cpp |
12 | mailtransport.cpp | ||
13 | mailtemplates.cpp | 11 | mailtemplates.cpp |
14 | retriever.cpp | 12 | retriever.cpp |
15 | accountfactory.cpp | 13 | accountfactory.cpp |
@@ -19,15 +17,12 @@ set(mailplugin_SRCS | |||
19 | ) | 17 | ) |
20 | add_definitions(-DMAIL_DATA_DIR="${CMAKE_CURRENT_SOURCE_DIR}/data") | 18 | add_definitions(-DMAIL_DATA_DIR="${CMAKE_CURRENT_SOURCE_DIR}/data") |
21 | 19 | ||
22 | find_package(CURL 7.20.0 REQUIRED) | ||
23 | find_package(KF5 REQUIRED COMPONENTS Package) | 20 | find_package(KF5 REQUIRED COMPONENTS Package) |
24 | 21 | ||
25 | include_directories(${CURL_INCLUDE_DIRS}) | ||
26 | |||
27 | add_library(mailplugin SHARED ${mailplugin_SRCS}) | 22 | add_library(mailplugin SHARED ${mailplugin_SRCS}) |
28 | 23 | ||
29 | qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets) | 24 | qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets) |
30 | target_link_libraries(mailplugin actionplugin settingsplugin sink KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes ${CURL_LIBRARIES}) | 25 | target_link_libraries(mailplugin actionplugin settingsplugin sink KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes) |
31 | 26 | ||
32 | add_subdirectory(actions/tests) | 27 | add_subdirectory(actions/tests) |
33 | 28 | ||