diff options
author | Christian Mollekopf <chrigi_1@fastmail.fm> | 2017-04-05 13:02:48 +0200 |
---|---|---|
committer | Christian Mollekopf <chrigi_1@fastmail.fm> | 2017-04-05 13:02:48 +0200 |
commit | 7c94d55f866794b2f1bb33b1f241552496b59b31 (patch) | |
tree | 675e547aeab1f9251934a96ff6c67a5e1980453c /framework/domain/CMakeLists.txt | |
parent | 5755ad47145d2985ba74354961b4127d82c516f6 (diff) | |
download | kube-7c94d55f866794b2f1bb33b1f241552496b59b31.tar.gz kube-7c94d55f866794b2f1bb33b1f241552496b59b31.zip |
Removed old files
Diffstat (limited to 'framework/domain/CMakeLists.txt')
-rw-r--r-- | framework/domain/CMakeLists.txt | 41 |
1 files changed, 0 insertions, 41 deletions
diff --git a/framework/domain/CMakeLists.txt b/framework/domain/CMakeLists.txt deleted file mode 100644 index e1482301..00000000 --- a/framework/domain/CMakeLists.txt +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | set(mailplugin_SRCS | ||
2 | attachmentmodel.cpp | ||
3 | mailplugin.cpp | ||
4 | maillistmodel.cpp | ||
5 | folderlistmodel.cpp | ||
6 | actions/sinkactions.cpp | ||
7 | objecttreesource.cpp | ||
8 | stringhtmlwriter.cpp | ||
9 | composercontroller.cpp | ||
10 | messageparser.cpp | ||
11 | messageparser_new.cpp | ||
12 | messageparser_old.cpp | ||
13 | mailtemplates.cpp | ||
14 | modeltest.cpp | ||
15 | retriever.cpp | ||
16 | outboxmodel.cpp | ||
17 | identitiesmodel.cpp | ||
18 | recepientautocompletionmodel.cpp | ||
19 | settings/accountsettings.cpp | ||
20 | selector.cpp | ||
21 | completer.cpp | ||
22 | controller.cpp | ||
23 | outboxcontroller.cpp | ||
24 | mailcontroller.cpp | ||
25 | foldercontroller.cpp | ||
26 | mouseproxy.cpp | ||
27 | contactcontroller.cpp | ||
28 | peoplemodel.cpp | ||
29 | ) | ||
30 | find_package(KF5 REQUIRED COMPONENTS Package) | ||
31 | |||
32 | add_library(mailplugin SHARED ${mailplugin_SRCS}) | ||
33 | |||
34 | qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets Test) | ||
35 | target_link_libraries(mailplugin actionplugin settingsplugin sink mimetreeparser KF5::MimeTreeParser KF5::Codecs KF5::Package KAsync) | ||
36 | |||
37 | |||
38 | install(TARGETS mailplugin DESTINATION ${FRAMEWORK_INSTALL_DIR}) | ||
39 | |||
40 | add_subdirectory(actions/tests) | ||
41 | add_subdirectory(mimetreeparser) | ||