summaryrefslogtreecommitdiffstats
path: root/framework/domain/CMakeLists.txt
diff options
context:
space:
mode:
authorSandro Knauß <sknauss@kde.org>2016-10-18 15:28:45 +0200
committerSandro Knauß <sknauss@kde.org>2016-10-18 15:28:45 +0200
commit0fa8aa51aac15233820b9f9c576584e6ff8ee151 (patch)
treeaeea1a5050fc353caaf95ed32c5abdcacf73aefb /framework/domain/CMakeLists.txt
parentd15a02d3c26c24530e8d9360629212e419c81c79 (diff)
downloadkube-0fa8aa51aac15233820b9f9c576584e6ff8ee151.tar.gz
kube-0fa8aa51aac15233820b9f9c576584e6ff8ee151.zip
use modeltest fromupstream to make sure, we have a valid model
Diffstat (limited to 'framework/domain/CMakeLists.txt')
-rw-r--r--framework/domain/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/framework/domain/CMakeLists.txt b/framework/domain/CMakeLists.txt
index 55bc2f24..a31bb016 100644
--- a/framework/domain/CMakeLists.txt
+++ b/framework/domain/CMakeLists.txt
@@ -10,6 +10,7 @@ set(mailplugin_SRCS
10 messageparser_new.cpp 10 messageparser_new.cpp
11 messageparser_old.cpp 11 messageparser_old.cpp
12 mailtemplates.cpp 12 mailtemplates.cpp
13 modeltest.cpp
13 retriever.cpp 14 retriever.cpp
14 accountfactory.cpp 15 accountfactory.cpp
15 accountscontroller.cpp 16 accountscontroller.cpp
@@ -22,7 +23,7 @@ find_package(KF5 REQUIRED COMPONENTS Package)
22 23
23add_library(mailplugin SHARED ${mailplugin_SRCS}) 24add_library(mailplugin SHARED ${mailplugin_SRCS})
24 25
25qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets) 26qt5_use_modules(mailplugin Core Quick Qml WebKitWidgets Test)
26target_link_libraries(mailplugin actionplugin settingsplugin sink mimetreeparser KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes) 27target_link_libraries(mailplugin actionplugin settingsplugin sink mimetreeparser KF5::MimeTreeParser KF5::Codecs KF5::Package KF5::Async KF5::IconThemes)
27 28
28add_subdirectory(actions/tests) 29add_subdirectory(actions/tests)
@@ -30,4 +31,4 @@ add_subdirectory(actions/tests)
30install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) 31install(TARGETS mailplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain)
31install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain) 32install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/domain)
32 33
33add_subdirectory(mimetreeparser) \ No newline at end of file 34add_subdirectory(mimetreeparser)