summaryrefslogtreecommitdiffstats
path: root/framework/actions/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2017-01-01 13:37:19 +0100
committerChristian Mollekopf <chrigi_1@fastmail.fm>2017-01-02 00:31:41 +0100
commitba7128b30850594c7efb258d1794e377eede364a (patch)
treef805d511f6d12b0799c05b414054db8b8635bfc9 /framework/actions/CMakeLists.txt
parent431c257dd29e2e3d8878db200f0de4d452bffe92 (diff)
downloadkube-ba7128b30850594c7efb258d1794e377eede364a.tar.gz
kube-ba7128b30850594c7efb258d1794e377eede364a.zip
Instead of using the action system we use controllers only.
It's simpler, and the action system was just too complex to use in a typesafe way.
Diffstat (limited to 'framework/actions/CMakeLists.txt')
-rw-r--r--framework/actions/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/framework/actions/CMakeLists.txt b/framework/actions/CMakeLists.txt
index 9cf0acd1..9fc43b9b 100644
--- a/framework/actions/CMakeLists.txt
+++ b/framework/actions/CMakeLists.txt
@@ -9,8 +9,10 @@ set(SRCS
9 9
10add_library(actionplugin SHARED ${SRCS}) 10add_library(actionplugin SHARED ${SRCS})
11 11
12target_link_libraries(actionplugin KF5::Async) 12target_link_libraries(actionplugin KF5::Async sink)
13qt5_use_modules(actionplugin Core Quick Qml) 13qt5_use_modules(actionplugin Core Quick Qml)
14 14
15install(TARGETS actionplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/actions) 15install(TARGETS actionplugin DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/actions)
16install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/actions) 16install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kube/framework/actions)
17
18add_subdirectory(tests)