diff options
author | Christian Mollekopf <chrigi_1@fastmail.fm> | 2016-01-04 23:24:43 +0100 |
---|---|---|
committer | Christian Mollekopf <chrigi_1@fastmail.fm> | 2016-01-05 13:41:40 +0100 |
commit | 021dde561b5ce86820013c681ff554b07590b052 (patch) | |
tree | b9d0b3b08efff6bd011544ef124c00ddec10012c /framework/actions/CMakeLists.txt | |
parent | dd09ca9ef4bb9780b953d6dd2999dbefe50bd1ff (diff) | |
download | kube-021dde561b5ce86820013c681ff554b07590b052.tar.gz kube-021dde561b5ce86820013c681ff554b07590b052.zip |
Prototype of the action system
Diffstat (limited to 'framework/actions/CMakeLists.txt')
-rw-r--r-- | framework/actions/CMakeLists.txt | 14 |
1 files changed, 14 insertions, 0 deletions
diff --git a/framework/actions/CMakeLists.txt b/framework/actions/CMakeLists.txt new file mode 100644 index 00000000..1151878c --- /dev/null +++ b/framework/actions/CMakeLists.txt | |||
@@ -0,0 +1,14 @@ | |||
1 | set(SRCS | ||
2 | actionplugin.cpp | ||
3 | action.cpp | ||
4 | actionhandler.cpp | ||
5 | actionbroker.cpp | ||
6 | context.cpp | ||
7 | ) | ||
8 | |||
9 | add_library(actionplugin SHARED ${SRCS}) | ||
10 | |||
11 | qt5_use_modules(actionplugin Core Quick Qml) | ||
12 | |||
13 | install(TARGETS actionplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/actions) | ||
14 | install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/actions) | ||