diff options
author | Christian Mollekopf <chrigi_1@fastmail.fm> | 2017-04-05 15:04:00 +0200 |
---|---|---|
committer | Christian Mollekopf <chrigi_1@fastmail.fm> | 2017-04-05 15:04:00 +0200 |
commit | 4b1798f0cdf87361869e7cf2b341acacd056c410 (patch) | |
tree | 3ff780641acdcb20b81f9b41533afd50a2525d38 /framework/CMakeLists.txt | |
parent | 71721aa4f3e85bea1a2fe504e86d99f80a3106a9 (diff) | |
download | kube-4b1798f0cdf87361869e7cf2b341acacd056c410.tar.gz kube-4b1798f0cdf87361869e7cf2b341acacd056c410.zip |
Moved cpp code into src directory
Diffstat (limited to 'framework/CMakeLists.txt')
-rw-r--r-- | framework/CMakeLists.txt | 72 |
1 files changed, 1 insertions, 71 deletions
diff --git a/framework/CMakeLists.txt b/framework/CMakeLists.txt index fda9b0a2..1fbd6994 100644 --- a/framework/CMakeLists.txt +++ b/framework/CMakeLists.txt | |||
@@ -16,85 +16,15 @@ include(KDEInstallDirs) | |||
16 | 16 | ||
17 | find_package(Qt5 COMPONENTS REQUIRED Core Qml) | 17 | find_package(Qt5 COMPONENTS REQUIRED Core Qml) |
18 | 18 | ||
19 | find_package(KF5MimeTreeParser "5.1.46" CONFIG REQUIRED) | ||
20 | find_package(KF5Mime "4.87.0" CONFIG REQUIRED) | ||
21 | find_package(Sink CONFIG REQUIRED) | ||
22 | find_package(KAsync CONFIG REQUIRED) | ||
23 | find_package(QGpgme CONFIG REQUIRED) | ||
24 | find_package(KF5Codecs CONFIG REQUIRED) | ||
25 | find_package(KF5Package CONFIG REQUIRED) | ||
26 | |||
27 | set(CMAKE_AUTOMOC ON) | 19 | set(CMAKE_AUTOMOC ON) |
28 | add_definitions("-Wall -std=c++0x -g") | ||
29 | include_directories(.) | ||
30 | include_directories(SYSTEM ${KDE_INSTALL_FULL_INCLUDEDIR}/KF5/) | ||
31 | include_directories(SYSTEM ${KDE_INSTALL_FULL_INCLUDEDIR}/KF5/KMime) | ||
32 | 20 | ||
33 | enable_testing() | 21 | enable_testing() |
34 | 22 | ||
35 | set(SINK_RESOURCE_PLUGINS_PATH ${QT_PLUGIN_INSTALL_DIR}/sink/resources) | ||
36 | set(FRAMEWORK_INSTALL_DIR ${QML_INSTALL_DIR}/org/kube/framework) | 23 | set(FRAMEWORK_INSTALL_DIR ${QML_INSTALL_DIR}/org/kube/framework) |
37 | 24 | ||
38 | install(DIRECTORY qml/ DESTINATION ${FRAMEWORK_INSTALL_DIR}) | 25 | install(DIRECTORY qml/ DESTINATION ${FRAMEWORK_INSTALL_DIR}) |
39 | install(FILES qmldir DESTINATION ${FRAMEWORK_INSTALL_DIR}) | 26 | install(FILES qmldir DESTINATION ${FRAMEWORK_INSTALL_DIR}) |
40 | 27 | ||
41 | set(SRCS | 28 | add_subdirectory(src) |
42 | frameworkplugin.cpp | ||
43 | actions/action.cpp | ||
44 | actions/actionhandler.cpp | ||
45 | actions/actionbroker.cpp | ||
46 | actions/actionresult.cpp | ||
47 | actions/context.cpp | ||
48 | settings/settings.cpp | ||
49 | domain/attachmentmodel.cpp | ||
50 | domain/maillistmodel.cpp | ||
51 | domain/folderlistmodel.cpp | ||
52 | domain/actions/sinkactions.cpp | ||
53 | domain/objecttreesource.cpp | ||
54 | domain/stringhtmlwriter.cpp | ||
55 | domain/composercontroller.cpp | ||
56 | domain/messageparser.cpp | ||
57 | domain/messageparser_new.cpp | ||
58 | domain/messageparser_old.cpp | ||
59 | domain/mailtemplates.cpp | ||
60 | domain/modeltest.cpp | ||
61 | domain/retriever.cpp | ||
62 | domain/outboxmodel.cpp | ||
63 | domain/identitiesmodel.cpp | ||
64 | domain/recepientautocompletionmodel.cpp | ||
65 | domain/settings/accountsettings.cpp | ||
66 | domain/selector.cpp | ||
67 | domain/completer.cpp | ||
68 | domain/controller.cpp | ||
69 | domain/outboxcontroller.cpp | ||
70 | domain/mailcontroller.cpp | ||
71 | domain/foldercontroller.cpp | ||
72 | domain/mouseproxy.cpp | ||
73 | domain/contactcontroller.cpp | ||
74 | domain/peoplemodel.cpp | ||
75 | accounts/accountfactory.cpp | ||
76 | accounts/accountsmodel.cpp | ||
77 | notifications/notificationhandler.cpp | ||
78 | ) | ||
79 | |||
80 | add_library(frameworkplugin SHARED ${SRCS}) | ||
81 | |||
82 | qt5_use_modules(frameworkplugin Core Quick Qml WebKitWidgets Test) | ||
83 | target_link_libraries(frameworkplugin sink mimetreeparser KF5::MimeTreeParser KF5::Codecs KF5::Package KAsync) | ||
84 | |||
85 | install(TARGETS frameworkplugin DESTINATION ${FRAMEWORK_INSTALL_DIR}) | ||
86 | |||
87 | # The actions framework | ||
88 | #add_subdirectory(actions) | ||
89 | # The settings framework | ||
90 | #add_subdirectory(settings) | ||
91 | # Domain specific domain logic | ||
92 | #add_subdirectory(domain) | ||
93 | # The accounts framework | ||
94 | #add_subdirectory(accounts) | ||
95 | # The notifications framework | ||
96 | #add_subdirectory(notifications) | ||
97 | add_subdirectory(domain/actions/tests) | ||
98 | add_subdirectory(domain/mimetreeparser) | ||
99 | 29 | ||
100 | feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES) | 30 | feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES) |