summaryrefslogtreecommitdiffstats
path: root/components/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2016-03-09 15:13:00 +0100
committerChristian Mollekopf <chrigi_1@fastmail.fm>2016-03-09 15:14:19 +0100
commit2dac72ae43f627340694d89db68184cb07e68650 (patch)
tree5397a5b6216bd05f9f48a219f379d59d64c8bde4 /components/CMakeLists.txt
parentda079fe211094621fbcb89614e58b84caa9a603b (diff)
downloadkube-2dac72ae43f627340694d89db68184cb07e68650.tar.gz
kube-2dac72ae43f627340694d89db68184cb07e68650.zip
Moved application to components
Diffstat (limited to 'components/CMakeLists.txt')
-rw-r--r--components/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/components/CMakeLists.txt b/components/CMakeLists.txt
new file mode 100644
index 00000000..2227e170
--- /dev/null
+++ b/components/CMakeLists.txt
@@ -0,0 +1,26 @@
1project(kube-components)
2
3cmake_minimum_required(VERSION 2.8.10.1)
4
5include(CPack)
6include(FeatureSummary)
7find_package(PkgConfig)
8
9################# set KDE specific information #################
10
11find_package(ECM 0.0.8 REQUIRED NO_MODULE)
12
13# where to look first for cmake modules, before ${CMAKE_ROOT}/Modules/ is checked
14set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
15
16include(KDEInstallDirs)
17include(KDECMakeSettings)
18include(KDECompilerSettings)
19
20find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui Widgets)
21
22set (QT_MIN_VERSION "5.4.0")
23find_package(KF5 REQUIRED COMPONENTS Package)
24
25# install UI package
26kpackage_install_package(package org.kde.kube.mail "genericqml")