summaryrefslogtreecommitdiffstats
path: root/accounts/maildir/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2016-03-03 22:30:07 +0100
committerChristian Mollekopf <chrigi_1@fastmail.fm>2016-03-03 22:30:07 +0100
commitfd31aa9b05ea215e8071cf76fe21ec746204f3a3 (patch)
treefd656cf389060e6a5c7ef3253d3337e0a48864c8 /accounts/maildir/CMakeLists.txt
parent54c3e5912b0d64bad5a1c66bc96f0552ac5e21f5 (diff)
downloadkube-fd31aa9b05ea215e8071cf76fe21ec746204f3a3.tar.gz
kube-fd31aa9b05ea215e8071cf76fe21ec746204f3a3.zip
Added a maildir configuration controller that can edit the config in
sink. The property binding only works when using actual QObject::property'ies. It doesn't work at all with Q_PROPERTY, even with a NOTIFY signal.
Diffstat (limited to 'accounts/maildir/CMakeLists.txt')
-rw-r--r--accounts/maildir/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/accounts/maildir/CMakeLists.txt b/accounts/maildir/CMakeLists.txt
index 7e9894b1..d83ae0be 100644
--- a/accounts/maildir/CMakeLists.txt
+++ b/accounts/maildir/CMakeLists.txt
@@ -20,8 +20,21 @@ include(KDECompilerSettings)
20find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui) 20find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui)
21 21
22set (QT_MIN_VERSION "5.4.0") 22set (QT_MIN_VERSION "5.4.0")
23find_package(KF5 REQUIRED COMPONENTS Package) 23find_package(Sink CONFIG REQUIRED)
24find_package(KF5Async CONFIG REQUIRED)
24 25
26include_directories(SYSTEM ${KDE_INSTALL_FULL_INCLUDEDIR}/KF5/)
27
28set(SRCS
29 maildirsettings.cpp
30 maildiraccountplugin.cpp
31)
32
33add_library(maildiraccountplugin SHARED ${SRCS})
34qt5_use_modules(maildiraccountplugin Core Quick Qml)
35target_link_libraries(maildiraccountplugin sink)
36
37install(TARGETS maildiraccountplugin DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir)
25install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir) 38install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir)
26install(FILES package/contents/ui/MaildirAccountSettings.qml DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir) 39install(FILES package/contents/ui/MaildirAccountSettings.qml DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir)
27 40