diff options
author | Christian Mollekopf <chrigi_1@fastmail.fm> | 2016-03-03 17:10:18 +0100 |
---|---|---|
committer | Christian Mollekopf <chrigi_1@fastmail.fm> | 2016-03-03 17:10:18 +0100 |
commit | 54c3e5912b0d64bad5a1c66bc96f0552ac5e21f5 (patch) | |
tree | 65b511dc68bd327d59cc320b04cb077a0a52e014 /accounts/maildir/CMakeLists.txt | |
parent | 7bc71c84a91d980f46bc042731ee903cef591031 (diff) | |
download | kube-54c3e5912b0d64bad5a1c66bc96f0552ac5e21f5.tar.gz kube-54c3e5912b0d64bad5a1c66bc96f0552ac5e21f5.zip |
Install a qml plugin for the maildir account
This works and allows us to register other controllers and action
handlers, but it's not yet clear to me whether we should rather be
using kpackage for this as well (and I failed to get it to run, so,
here we are...)
Diffstat (limited to 'accounts/maildir/CMakeLists.txt')
-rw-r--r-- | accounts/maildir/CMakeLists.txt | 27 |
1 files changed, 27 insertions, 0 deletions
diff --git a/accounts/maildir/CMakeLists.txt b/accounts/maildir/CMakeLists.txt new file mode 100644 index 00000000..7e9894b1 --- /dev/null +++ b/accounts/maildir/CMakeLists.txt | |||
@@ -0,0 +1,27 @@ | |||
1 | project(kube-accounts-maildir) | ||
2 | |||
3 | cmake_minimum_required(VERSION 2.8.10.1) | ||
4 | |||
5 | include(CPack) | ||
6 | include(FeatureSummary) | ||
7 | find_package(PkgConfig) | ||
8 | |||
9 | ################# set KDE specific information ################# | ||
10 | |||
11 | find_package(ECM 0.0.8 REQUIRED NO_MODULE) | ||
12 | |||
13 | # where to look first for cmake modules, before ${CMAKE_ROOT}/Modules/ is checked | ||
14 | set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR}) | ||
15 | |||
16 | include(KDEInstallDirs) | ||
17 | include(KDECMakeSettings) | ||
18 | include(KDECompilerSettings) | ||
19 | |||
20 | find_package(Qt5 REQUIRED NO_MODULE COMPONENTS Core Quick Test Gui) | ||
21 | |||
22 | set (QT_MIN_VERSION "5.4.0") | ||
23 | find_package(KF5 REQUIRED COMPONENTS Package) | ||
24 | |||
25 | install(FILES qmldir DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir) | ||
26 | install(FILES package/contents/ui/MaildirAccountSettings.qml DESTINATION ${QML_INSTALL_DIR}/org/kde/kube/accounts/maildir) | ||
27 | |||