summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mollekopf <chrigi_1@fastmail.fm>2017-08-23 18:39:44 -0600
committerChristian Mollekopf <chrigi_1@fastmail.fm>2017-08-23 18:39:44 -0600
commit85dc437da27417cce05b5a9f97505b43cfdf4dee (patch)
tree3b6984e9f42a085fae821d4024326987a48fdc98 /CMakeLists.txt
parent25b4f6e2d7ed2d783b8ee1eefbe62df713ca0341 (diff)
downloadkube-85dc437da27417cce05b5a9f97505b43cfdf4dee.tar.gz
kube-85dc437da27417cce05b5a9f97505b43cfdf4dee.zip
The grand cmake cleanup
We had a ton of duplication in our cmake code because we had no common toplevel settings. This is now cleaned up so we can sanely change settings and so we know what we have set.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 18 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3fe755e9..611a19ee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,18 +1,31 @@
1cmake_minimum_required(VERSION 3.0) 1cmake_minimum_required(VERSION 3.0)
2 2
3cmake_policy(SET CMP0048 NEW) 3project(kube VERSION 0.4)
4
5set (QT_MIN_VERSION "5.7.0")
6
7cmake_policy(SET CMP0011 NEW)
4cmake_policy(SET CMP0028 NEW) 8cmake_policy(SET CMP0028 NEW)
9cmake_policy(SET CMP0048 NEW)
10cmake_policy(SET CMP0053 NEW)
5cmake_policy(SET CMP0063 NEW) 11cmake_policy(SET CMP0063 NEW)
6 12
7project(kube VERSION 0.4) 13include(CPack)
8set (QT_MIN_VERSION "5.7.0") 14include(FeatureSummary)
15find_package(PkgConfig REQUIRED)
16find_package(ECM 5.29.0 REQUIRED NO_MODULE)
17
18set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
19
20include(KDEInstallDirs)
21include(KDECompilerSettings)
22include(KDECMakeSettings NO_POLICY_SCOPE)
9 23
10enable_testing() 24enable_testing()
11 25
12add_subdirectory(framework) 26add_subdirectory(framework)
13add_subdirectory(components) 27add_subdirectory(components)
14add_subdirectory(accounts)
15add_subdirectory(icons) 28add_subdirectory(icons)
16add_subdirectory(applications) 29add_subdirectory(applications)
17 30add_subdirectory(accounts)
18add_subdirectory(tests) 31add_subdirectory(tests)