diff options
author | Christian Mollekopf <chrigi_1@fastmail.fm> | 2017-08-23 18:39:44 -0600 |
---|---|---|
committer | Christian Mollekopf <chrigi_1@fastmail.fm> | 2017-08-23 18:39:44 -0600 |
commit | 85dc437da27417cce05b5a9f97505b43cfdf4dee (patch) | |
tree | 3b6984e9f42a085fae821d4024326987a48fdc98 /CMakeLists.txt | |
parent | 25b4f6e2d7ed2d783b8ee1eefbe62df713ca0341 (diff) | |
download | kube-85dc437da27417cce05b5a9f97505b43cfdf4dee.tar.gz kube-85dc437da27417cce05b5a9f97505b43cfdf4dee.zip |
The grand cmake cleanup
We had a ton of duplication in our cmake code because we had no common
toplevel settings. This is now cleaned up so we can sanely change
settings and so we know what we have set.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r-- | CMakeLists.txt | 23 |
1 files changed, 18 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt index 3fe755e9..611a19ee 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt | |||
@@ -1,18 +1,31 @@ | |||
1 | cmake_minimum_required(VERSION 3.0) | 1 | cmake_minimum_required(VERSION 3.0) |
2 | 2 | ||
3 | cmake_policy(SET CMP0048 NEW) | 3 | project(kube VERSION 0.4) |
4 | |||
5 | set (QT_MIN_VERSION "5.7.0") | ||
6 | |||
7 | cmake_policy(SET CMP0011 NEW) | ||
4 | cmake_policy(SET CMP0028 NEW) | 8 | cmake_policy(SET CMP0028 NEW) |
9 | cmake_policy(SET CMP0048 NEW) | ||
10 | cmake_policy(SET CMP0053 NEW) | ||
5 | cmake_policy(SET CMP0063 NEW) | 11 | cmake_policy(SET CMP0063 NEW) |
6 | 12 | ||
7 | project(kube VERSION 0.4) | 13 | include(CPack) |
8 | set (QT_MIN_VERSION "5.7.0") | 14 | include(FeatureSummary) |
15 | find_package(PkgConfig REQUIRED) | ||
16 | find_package(ECM 5.29.0 REQUIRED NO_MODULE) | ||
17 | |||
18 | set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR}) | ||
19 | |||
20 | include(KDEInstallDirs) | ||
21 | include(KDECompilerSettings) | ||
22 | include(KDECMakeSettings NO_POLICY_SCOPE) | ||
9 | 23 | ||
10 | enable_testing() | 24 | enable_testing() |
11 | 25 | ||
12 | add_subdirectory(framework) | 26 | add_subdirectory(framework) |
13 | add_subdirectory(components) | 27 | add_subdirectory(components) |
14 | add_subdirectory(accounts) | ||
15 | add_subdirectory(icons) | 28 | add_subdirectory(icons) |
16 | add_subdirectory(applications) | 29 | add_subdirectory(applications) |
17 | 30 | add_subdirectory(accounts) | |
18 | add_subdirectory(tests) | 31 | add_subdirectory(tests) |